CloudFlare Service Disruption
Incident Report for GlowFrog Hosting Status
Resolved
CloudFlare has marked the incident as resolved: https://www.cloudflarestatus.com/incidents/zbzjv8sm3g94 all services should have returned to normal.
Posted Jun 02, 2021 - 21:09 UTC
Identified
We have identified a service disruption relating to CloudFlare. We are working closely with CloudFlare to resolve this and will continue to post updates as they become available.

CloudFlare has posted a status page on this here: https://www.cloudflarestatus.com/?_ga=2.147298547.531433793.1622658884-1818120348.1618946799
Posted Jun 02, 2021 - 18:35 UTC
This incident affected: Hosting Services (CloudFlare).